Spend has fully ramped up and the incident is now stands fully resolved.
Posted Jul 24, 2026 - 06:39 PDT
Update
AWS have confirmed the incident has been resolved on their end. We've also observed that access to Quantcast Platform UI has been fully restored. We're in the process of ramping up spend which should complete in the next 30-60 minutes.
We're continuing to monitor for any issues.
Posted Jul 24, 2026 - 06:38 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 06:34 PDT
Monitoring
AWS are seeing initial signs of recovery, and the platform UIs are accessible for some users now. Spend remains temporarily disabled as we await a full recovery from the earlier incident. We will continue to monitor and post updates here.
Posted Jul 24, 2026 - 05:01 PDT
Update
AWS are seeing initial signs of recovery, and the platform UIs are accessible for some users now. Spend remains temporarily disabled as we await a full recovery from the earlier incident. We will continue to monitor and post updates here.
Posted Jul 24, 2026 - 05:01 PDT
Identified
AWS have confirmed the outage and some of the services impacted are resulting in the outage of the Quantcast platform. Majority of our systems are affected due to this including spend and access to the platform UI.
We are currently investigating the outage of Quantcast platform. It's likely due to AWS cloud infrastructure outage that has impacted almost all of our services. More details to follow.
Posted Jul 24, 2026 - 04:33 PDT
This incident affected: Quantcast Platform for Marketers (Login and Authorization, Campaign Management, Planner, Creative Management, Inventory Management, Q Pixel, Reporting, Campaign Delivery, Welcome Page) and Quantcast Platform for Publishers (Planner).