Campaigns not delivering

Incident Report for Quantcast

Resolved

This incident has been resolved. Delivery and spend are returning to normal levels for all campaigns.
Posted Oct 16, 2024 - 15:05 PDT

Update

We are continuing to investigate this issue.
Posted Oct 16, 2024 - 13:44 PDT

Update

Problem has been identified and fix is underway. Campaign delivery and spend have partially recovered.
Posted Oct 16, 2024 - 13:27 PDT

Investigating

We are currently investigating this issue.
Posted Oct 16, 2024 - 13:12 PDT
This incident affected: Quantcast Platform for Marketers (Campaign Delivery).