The issue affecting campaign editing has been fully resolved. The implemented fix has been verified, and system metrics have returned to normal. We apologize for any inconvenience this may have caused.
Posted Jul 24, 2026 - 13:11 PDT
Update
Our team is currently performing validation checks to confirm that the issue with campaign editing has been completely resolved. We will provide a final update shortly.
Posted Jul 24, 2026 - 12:35 PDT
Monitoring
A fix has been implemented, and we are currently monitoring campaign management to ensure stability.
Posted Jul 24, 2026 - 11:50 PDT
Identified
The root cause of the issue has been identified, and the team is currently validating a fix.
Posted Jul 24, 2026 - 11:44 PDT
Investigating
We are currently investigating an issue affecting campaign management.
Posted Jul 24, 2026 - 11:32 PDT
This incident affected: Quantcast Platform for Marketers (Campaign Management).