Quantcast Platform for Marketers - UI unavailable

Incident Report for Quantcast

Resolved

The issue has now been resolved
Posted Feb 19, 2025 - 04:17 PST

Identified

The Quantcast Platform is currently unavailable. Our engineering team has identified the issue and is actively implementing a fix. Campaign delivery remains unaffected.
Posted Feb 19, 2025 - 04:00 PST
This incident affected: Quantcast Platform for Marketers (Login and Authorization, Campaign Management, Planner, Creative Management, Inventory Management, Q Pixel, Reporting).